Domino Configuration and Restore error

Last post 09-09-2016, 5:07 AM by JP2013. 19 replies.
Sort Posts: Previous Next
  • Domino Configuration and Restore error
    Posted: 06-26-2016, 2:55 PM

    Hi Guys,

    I require some assistance with the deployment and configuration of the IBM Domino agent.

    The Domino setup is as below:
    Primary server
    Secondary server
    Replication configured between the servers

    I installed the Domino database agent on the secondary server to test backup and restores while the load is all on the primary server.

    I created a new subclient and discovered a couple of mailboxes.
    This is the strange part for me since I deployed the database agent I was able to see individual mailboxes.
    Is this normal?

    I ran a test backup and could see the job reporting that data was transferred.

    The Domino admin created a test mailbox on the secondary server which was not enabled for replication.
    I ran the backup successfully.

    Then I attempted an out of place restore of this mailbox to the secondary server.
    I did not change any of the replication option in the job since this is a test and was out of place.

    During the restore of the test mailbox the job was stuck in the Pre-Restore phase.
    After about 10 minutes it was discovered that the secondary Domino server crashed and restarted.

    So from here 2 questions:
    1. Is the setup correct for the database level backup?

    2. Can a restore job cause the server to crash and restart?

    Much appreciated.

  • Re: Domino Configuration and Restore error
    Posted: 08-19-2016, 5:00 PM

    Hi Pal,

    Q1. Is the setup correct for the database level backup?

    Answer: So far so good. What matters is whether the agent can find the following:

    Name of the Domino instance
    Path to the directory where the instance resides
    Path to the directory where the Domino software resides

    http://documentation.commvault.com/commvault/v10/article?p=products/lotus_notes_db/deployment.htm


    Q2. Can a restore job cause the server to crash and restart?

    Answer: Possible. WHY?

    (a) The following requirements have not been met:

    Notes Database Restore Consideration:
    https://documentation.commvault.com/commvault/v10/article?p=products/lotus_notes_db/best_practices.htm

    In a Domino environment, data restored on one server will not propagate to other servers within the Domino environment. The restored databases will be overwritten by the existing databases during replication. If you do not want the databases to be overwritten, from the Restore Options dialog box, select the Disable Replication check box before running a restore job.

    Disabling Replication of Restored Databases:
    https://documentation.commvault.com/commvault/v10/article?p=products/lotus_notes_db/restore_adv.htm#Disabling_Replication_of_Restored_Databases

    (b) The wrong agent is being used to restore a mailbox - The Notes Database iDataAgent is designed to be used as a disaster recovery tool. Use this iDataAgent if your primary goal is full database recovery in the event of a database or system crash rather than small day-to-day restore jobs.

    Overview - IBM Domino iDataAgents:
    http://documentation.commvault.com/commvault/v10/article?p=prod_overview/lotus_notes.htm

    The Notes Document iDataAgent is designed to protect individual documents of a database. These might be data or design documents. Use the Notes Document iDataAgent if your primary goal is partial database recovery.


    Best Practices:
    - Notes Document iDataAgent: http://documentation.commvault.com/commvault/v10/article?p=products/lotus_notes_doc/best_practices.htm
    - Notes Database iDataAgent: http://documentation.commvault.com/commvault/v10/article?p=products/lotus_notes_db/best_practices.htm


    Kind Regards


    Jim
  • Re: Domino Configuration and Restore error
    Posted: 08-22-2016, 4:15 AM

    Hi Jim,

    Thanks for the response.

    I deployed the database agent via the console. It discovered the instance and I could see all the databases when running a discover operation against the subclient.

    My question relates to the fact that I am able to both user mailboxes and the templates along with databases in the list.

    How do I distinguish between databases that forms part of the document level and the others that will form part of the database level backup?

    When I look at it both are seen by Domino as databases.

     

    Hence the reason for my question if the a restore can crash the server.

    I think I backed up a user mailbox with the database agent the performed an out-of-place restore that caused the server to crash.

    After this I read the documentation again and it became clear that the logging should be changed to archive mode.

    My question still remains on the identification of the user mailboxes compared to the actual databases.

     

    Can you assist with some guidance here?

     

    Thanks.

    Ignes

  • Re: Domino Configuration and Restore error
    Posted: 08-22-2016, 11:45 PM

    Hi Ignes,

    The answer is simple, the DB Agent will encompass everything just as you have already seen. But the Document agent will focus on the document (email) level thus providing the ablility to backup and be able to restore real documents at a granular (brick-level). 

    Just like the documentation links I provided indicate, you cannot get that granularity with the DB agent.

    Best practice is to make sure that items representing some kind of “design notes” class (which are NOT real documents) should be targeted by the DB agents, not the Document agent. For example:

    *.ntf
    LOG.NSF
    names.nsf
    NA\usbnames.nsf
     
    Kind Regards
    Jim

     

  • Re: Domino Configuration and Restore error
    Posted: 08-24-2016, 1:50 AM

    Thanks for the reply.

    No I sit with an issue trying to deploy the Document agent.

    I receive the below error:

    Error: Failed to register the client to CommServe.
    5524  1     08/23 15:52:45 ### ### ### - Server Error:  (Error) Could not configure indexing subclients for [iDA for Domino Document]. [67109557].

     

    Any ideas?

     

    Thanks.

    Ignes

  • Re: Domino Configuration and Restore error
    Posted: 08-24-2016, 3:27 AM

    Hi Ignes,

    The latest errors mean presence of deprecated components such as "SRM agent" etc on the computer where you are trying to install the Notes Document agent.

    Examine the CommVault Installer log and InstallerError log from the [programdata] folder on that machine and attach copies here if you can. 

    That will tell you exactly which software components are hindering progress.

    You can safely remove the problematic components and restart the deployment.

    Thank you.

    Jim



  • Re: Domino Configuration and Restore error
    Posted: 08-24-2016, 9:30 AM

    Hi Jim,

    When trying a push install from the Console it fails with the attached in the logs. InstallErrors file is empty.

    I must admin that I leave the Domino information empty for the partition and data directories, etc...

    When confirming if it has installed the agent by running an Uninstall on the ContentStore it lists Domino Document there to be uninstalled. Not sure how.



    I then uninstall the Domino agent manually from the server - see InstallCleanUp file.



    Then install again from a package I created.
    To an existing instance001.
    A partition is detected and I select it - DOMTST in this instance.

    It then fails with the same error displayed.

    I dont see any depracated software installed on this server. Definately not from a Commvault point of view.

     

    Thanks.

    Ignes

    Attachment: Install-Logs.zip
  • Re: Domino Configuration and Restore error
    Posted: 08-24-2016, 9:52 AM

    Another thing - is there any special permissions required with Notes?

    Thanks.

  • Re: Domino Configuration and Restore error
    Posted: 08-24-2016, 2:21 PM

    Hi Ignes

     

    Sorry I did not find the installer file logs you attached. Please help.

     

    Thank you

     

    Jim

  • Re: Domino Configuration and Restore error
    Posted: 08-24-2016, 2:49 PM

    Hi,

    I am attaching it again.

     

    I was able to deploy the Domino Database agent without any issues.

    Thanks.

    Ignes

    Attachment: Install-Logs.zip
  • Re: Domino Configuration and Restore error
    Posted: 08-26-2016, 1:57 AM

    Hi Ignes,

    Thank you again I found the logs.

    I found our v11SP4 updates that seem to resolve a number of installer issues. Just wondering what version is the client machine on at the moment?

    Please see this: ( https://documentation.commvault.com/commvault/v11/article?p=service_pack/updates/sp4.htm )

    There are 44 updates released to be installed on top of SP4 - https://ma.commvault.com/SoftwareUpdates?fv=11.0&searchText=&selectedSP=4&selectedPlatform=winx64  

    Try to patch up and let me know how you get on.

    If the issue remain attach a new CVInstallMgr.log and Install.log

    Thank you

    Jim

     

     

     

     

     

     

     

     

     

     

  • Re: Domino Configuration and Restore error
    Posted: 08-26-2016, 6:37 AM

    Hi.

    Both CS and client is on v11 SP2.

     

    Regards,

    Ignes

  • Re: Domino Configuration and Restore error
    Posted: 08-26-2016, 9:51 AM

    Hi Ignes,

    Get them to SP4, that should solve that issue. Confirmed.

    Kind Regards

    Jim

  • Re: Domino Configuration and Restore error
    Posted: 08-31-2016, 9:06 AM

    Hi Jim,

    I upgraded to SP4 and the installation now succeeds.

    I am able to backup the mailboxes and restore out of place.

    What is refferred to by the Design & Data section when browsing for a restore?

     

    And to confirm - I am able to deploy both the database and document agent on the same client?

     

    Do I require a seperate server to restore a db out of place?

     

    Cheers.

    Ignes

  • Re: Domino Configuration and Restore error
    Posted: 09-01-2016, 7:07 AM

    Hi Jim,

     

    I have now backed up a couple of mailboxes and I was able to restore out of place.

    However when browsing the Data Documents to restore individual items the available fields are ID, Attachment and Type only.

    How would you go about identifying a specific mail?

     

    Regards,

    Ignes

  • Re: Domino Configuration and Restore error
    Posted: 09-01-2016, 7:26 AM

    Hi Ignes,

    Would you kindly post a screenshot of that description so I can understand what exactly how else to help?

    Thank you

    Jim

  • Re: Domino Configuration and Restore error
    Posted: 09-01-2016, 1:59 PM

    Hi.

    I have attached it.

    Thanks.


    Attachment: Restore.jpg
  • Re: Domino Configuration and Restore error
    Posted: 09-02-2016, 2:10 AM

    Hi Ignes,

    You need to define a Notes Application level ($All) views feature first.

    The agent reads this view during to backup and restore and will only be able to display hidden views in Notes if that feature is defined correctly. 

    How you define ($All) views depends on the version you have. I am sure the Notes Admin can help with that. 

    Once defined, then run another backup / restore and observe the change.

    Thank you

    Jim

  • Re: Domino Configuration and Restore error
    Posted: 09-09-2016, 5:00 AM

    Hi Jim.

    I never got to actually see the result as the decision was changed to Database level backups again.

    Thanks for the info in anycase.

    Cheers.

    Ignes

  • Re: Domino Configuration and Restore error
    Posted: 09-09-2016, 5:07 AM

    Hi Ignes,

    Thank you so much for updating me on this and for ending the thread, much appreciated. Have a great weekend.

    Regards

    Jim

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy