Failed to get files from solr DB

Last post 01-21-2020, 3:55 AM by Wwong. 3 replies.
Sort Posts: Previous Next
  • Failed to get files from solr DB
    Posted: 01-14-2020, 9:45 AM

    Hi!

    Since upgrade from 11.15 to 11.17, backup of index server cmplete with error.

    In the logs I have found 'Failed to get files from solr DB'...  any idea how to check/fix the configuration?

    Thanks, Kay

  • Re: Failed to get files from solr DB
    Posted: 01-19-2020, 4:36 AM

    Hi Kay 

    What's the purpose of the Index Server, is this for a Storage Policy, Analytics or etc?

    Can you provide further error logging ?

    Regards

    Winston

  • Re: Failed to get files from solr DB
    Posted: 01-20-2020, 10:37 AM

    Hi Winston,

    analytics, dynamicIndexInstance.  Have reconfigured the roles without success.

    Backup complets with error with event event

        SolrDB status check failed for [FileSystem Index]

    I can not open the page

        http://server:20000

    but I can access

        http://server:20000/solr/#/

    Following entries from the logs.

        01/20 15:57:54 5310150 CWorkerSolrIndex::Run(91) - Worker thread failed, ignoring failure for solr content, 0x80070306:{CWorkerBasic::Run(3644)} + {CWorkerBasic::ProcessScan(3681)} + {CWorkerSolrIndex::TryScanners(165)} + {CWorkerSolrIndex::ProcessPathsUsingSolrDB(250)/Failed to get files from solr DB} + {CSolrIndexApi::GetAllFiles(67)} + {CSolrIndexApiPrivate::GetAllSolrDBCores(208)/W32.774.(One or more errors occurred while processing the request.)-Error, No core received}
        01/20 15:57:56 5310150 CFindSolrIndexBackup::ProcessThreadStatus(283) - Failed to process solrRole [FileSystem Index], collect [...\NumColTot2.tmp]
        01/20 15:57:56 5310150 CFind::HandleError(9936) - Directory [FileSystem Index] open failed, error=[0x2 2] The system cannot find the file specified.

    Regards, Kay

  • Re: Failed to get files from solr DB
    Posted: 01-21-2020, 3:55 AM

    Hi Kay 

    The fact that SOLR is accessible, I don't believe the issue is on the SOLR DB. 

    It looks like the client property attribute stored in the CSDB might not be correct, this could be why the Backup of the Index Server is failing 

    If there is a miss-match or a missing attribute in the CSDB, an update of the DB will be required. 

    But to update this entry you will need to engage Support to confirm further. 

    Regards

    Winston 

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2020 Commvault | All Rights Reserved. | Legal | Privacy Policy