CommVault Forums

Solving Forward - Solving Together
Welcome to CommVault Forums Sign in | Join | Help
in

questions on multiplexing to tape

Last post 01-22-2013, 5:26 PM by Nevaduh. 7 replies.
Sort Posts: Previous Next
  • questions on multiplexing to tape
    Posted: 01-10-2013, 10:37 AM

    I've seen in a few places that multiplexing streams from different data types (such as files and databases) isn't recommended.  Is this purely due to decreased restore performance or is there an impact to reliability as well?  I'm looking for ways to speed up our write performance to tape because we're only getting 60GB/hr to LTO-5.

    Thanks!


    -Josh
  • Re: questions on multiplexing to tape
    Posted: 01-16-2013, 8:51 AM

    Restore decrease would certainly be the main reason.  The 60GB/hr is certainly slow.  When you do drive validation what speeds are you seeing.

  • Re: questions on multiplexing to tape
    Posted: 01-17-2013, 10:55 AM

    Are you performing an AUX copy from your primary disk or backing straight up to tape? Are you using any type of tape encryption? You are able to use multiplexing for databases when streaming to tape. The down side is you have to create an aux copy in the same storage policy to copy the data back on to disk before peroforming a restore. Its perty simple and does not take that long to do. I think the benfits of multiplexing to tape to tape out weigh the fact you have to re-hydrate it back to disk before performing the restore.

  • Re: questions on multiplexing to tape
    Posted: 01-17-2013, 10:57 AM

    Vincenzo_Basolino:

    Restore decrease would certainly be the main reason.  The 60GB/hr is certainly slow.  When you do drive validation what speeds are you seeing.

     

    I'll run the drive validation when the current jobs are caught up and see.


    -Josh
  • Re: questions on multiplexing to tape
    Posted: 01-17-2013, 11:00 AM

    Nmendias:

    Are you performing an AUX copy from your primary disk or backing straight up to tape? Are you using any type of tape encryption? You are able to use multiplexing for databases when streaming to tape. The down side is you have to create an aux copy in the same storage policy to copy the data back on to disk before peroforming a restore. Its perty simple and does not take that long to do. I think the benfits of multiplexing to tape to tape out weigh the fact you have to re-hydrate it back to disk before performing the restore.

    This is Aux from disk.  Primary is dedup.  Aux copy is going non-dedup with hardware encryption.  I did some testing with 4x multiplexing and I'm seeing writes consistenly over 200G/Hr now.  We just got a new MA which I think will help as well, since the current MA wasn't originally designed with CommVault in mind.


    -Josh
  • Re: questions on multiplexing to tape
    Posted: 01-17-2013, 11:37 AM

    Take a look at the document look at the resolution part this will help creating the aux copy back to disk.  We have perform this several times with no issues.  Just a side note we use to use hardware encryption but decided to software encryption with Commvault. We are using AES stay away from 3-des its slows down your aux copy. Then there is not another key manger you have to manage its all in commvault.

  • Re: questions on multiplexing to tape
    Posted: 01-22-2013, 4:51 PM

    JoshCurrier:

    I've seen in a few places that multiplexing streams from different data types (such as files and databases) isn't recommended.  Is this purely due to decreased restore performance or is there an impact to reliability as well?  I'm looking for ways to speed up our write performance to tape because we're only getting 60GB/hr to LTO-5.

    Thanks!

    I have a 2 drive library with a 30 tape storage.   So you want to run two Streams and a multiplexing factor of 5.   So it ends up with 5 feeds to each drive and I have consistant throughput averages doing like 14 TB of data of over 500 GB per hour.  Sometimes burst of 800 GPH

     

  • Re: questions on multiplexing to tape
    Posted: 01-22-2013, 5:26 PM

    Here is my settingSmile


    Attachment: MultiPlexing.jpg
The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of CommVault Systems, Inc. ("CommVault") and CommVault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, CommVault.
CommVault, CommVault and logo, the “CV” logo, CommVault Systems, Solving Forward, SIM, Singular Information Management, Simpana, CommVault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of CommVault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2014 CommVault | All Rights Reserved. | Legal | Privacy Policy