Intellisnap vmware with dell compellent

Last post 10-11-2017, 9:20 AM by greenwellz. 4 replies.
Sort Posts: Previous Next
  • Intellisnap vmware with dell compellent
    Posted: 10-02-2013, 11:05 AM

    I have an dell compellent and an Cluster Vmware (4 esx) all connected in ISCSI.

    The commvault is the V10

    I try to use intellisnap to do my backup, the snap works great, i can see the new lun created into the dell compellent, but when the software try to mount the snap into the Esx proxy (ESX not part of cluster) it failed !

     

    6220  58    10/02 14:15:45 2510 CVSnapClientAPI::setJPR() - Setting JPR Job Id [2510] Err [60611] EvErr [1040189270] ErrStr [VMWare Mount snapshot failed. (MM.60611)]
    6220  58    10/02 14:15:45 2510 CVSnapClientAPI::setJPR() - JPR Set - Error [60611, VMWare Mount snapshot failed. (MM.60611)] Custom Error []
    6220  58    10/02 14:15:45 2510 CVSnapClientAPI::mountVolumes() - Request for mountVolumes Failed. Status [-1].
    6220  58    10/02 14:15:45 2510 CVMWareInfo::MountSnap() - Failed to mount snapshots with error [60611]
    6220  58    10/02 14:15:45 2510 CheckVMInfoError() - Error mounting snap volumes
    6220  58    10/02 14:15:45 2510 CheckVMInfoError() - VM [Memnon] Error mounting snap volumes.
    6220  58    10/02 14:15:45 2510 VSBkpSnapController::InitMovingToTapePhase() - MountSnap Failed for Moving to tape Phase.

     

     

    In VMware the esx proxy can see the lun but I have message like  :

    Login to iSCSI target iqn.2002-03.com.compellent:5000d310002ea52c on
    vmhba41 @ vmk1 failed. The iSCSI initiator could not establish a network
    connection to the target.
    error
    2/10/2013 16:51:14
    vmwesxcommvault

    Any idea ?

     

     

    Thanks

  • Re: Intellisnap vmware with dell compellent
    Posted: 10-02-2013, 5:00 PM

    mulitple nics and its going over the wrong one?

  • Re: Intellisnap vmware with dell compellent
    Posted: 10-03-2013, 6:09 AM

    are you using both FC and iSCSI on this VSA? if so use the registry key below. The other registry key we could use is the sPortInfo key which tells it to use a specific HBA for the mount. By default we try the first one in the list.

    without the logs i am just guessing where the mount is failing. These are 2 common keys we can try.

     Registry Keys:

    Windows HKEY_LOCAL_MACHINE\SOFTWARE\CommVault Systems\Galaxy\Instance<xxx>\iDataAgent
    Unix Not Applicable
    NetWare Not Applicable
    Key nIscsiEnable (optional)
    Value Not Applicable
    Value Type DWORD
    Valid Range 0 or 1 (0 = disable, 1 = enable)
    Default Value 0
    Created in Client computer on which the Virtual Server iDataAgent is installed
    Description This registry key is used when performing a SnapProtect backup for a VMware virtual machine. When the key is enabled, the backup data will always try to mount using the iSCSI method.
    Additional Information You may find additional information in Advanced - VMware SnapProtect Backup - Mount Snapshots.
    Applies To Virtual Server iDataAgent

     

     

    Windows HKEY_LOCAL_MACHINE\SOFTWARE\CommVault Systems\Galaxy\Instance<xxx>\iDataAgent
    Unix Not Applicable
    NetWare Not Applicable
    Key sPortInfo
    Value <HBA address>

    Do not use colon (:) while specifying the HBA address if you are using FC Protocol. For example: 210000e08b804d0a

    Value Type STRING
    Valid Range N/A
    Default Value Not Applicable
    Created in Client computer on which the Virtual Server iDataAgent is installed
    Description This registry key is used when mounting a snapshot on an ESX server. The snapshot will exposed to the specified Host Bus Adapter (HBA).
    Additional Information You may find additional information in Advanced - VMware SnapProtect Backup - Snap Mount to a different ESX server .
    Applies To Virtual Server iDataAgent

     

     

     

     


    Client Team Supervisor - Focus on Virtualization
    Follow me on Twitter - @wfarinella
  • Re: Intellisnap vmware with dell compellent
    Posted: 10-03-2013, 12:05 PM

    No I only use one ISCSI and there is no FC card installed.

    the first key nIscsiEnable is installed, not the second because is only for FC

  • Re: Intellisnap vmware with dell compellent
    Posted: 10-11-2017, 9:20 AM

    We have the exact same issue. We use FC and not iSCSI. Was there ever a resolution to this issue. All my searches in books online have come up null.  

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2017 Commvault | All Rights Reserved. | Legal | Privacy Policy