CommVault SLA report showing old VMWARE servers still

Last post 03-19-2018, 7:35 AM by Henrico County. 14 replies.
Sort Posts: Previous Next
  • CommVault SLA report showing old VMWARE servers still
    Posted: 09-29-2014, 12:41 PM

    We have gotten rid of some of these servers 6 months ago, but they are still showing up on the SLA 30 day report as not being backed up.  Shows last job end as of April of 2014.  Is there a way to get rid of these off the reports or another place that CommVault is looking?  It is causing our SLA to go down and I am unable to get them off that report when they are no longer in VMWARE or being backedup anywhere.

  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 09-29-2014, 12:45 PM

    are the clients still in the GUI ?

    By default when backing up a VM Ware server we will create dummy clients for each VM that is backed up so we can track backup history at a per-vm level. 

    Even if the VM was deleted from the VM Ware server, the dummy client entry would not have been cleaned up from the database. 

    These dummy clients are not visible by default so you will have to go into Control Panel -> User Preferences -> (Client Computer Filter) OR (Client Computer Group Filter) 

    Select then checkbox for "Show Virtual Machines", then you should be able to see the dummy client and hard delete it if you want to remove the history and remove it from SLA


    Wearer of Many Hats
  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 09-29-2014, 1:07 PM

    The dummy client was the issue. Once I turned that on, I found them and removed them!

    So I assume when we remove VMWARE servers we now need to go into CommVault and do this same thing as well?

  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 09-29-2014, 1:10 PM

    I am unclear what the behavior is if we delete the entire server, but my best assumption would be that these clients would still have to be deleted manually. 

    I do not have a test server that i can delete at the moment to try it out. 


    Wearer of Many Hats
  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 09-29-2014, 2:53 PM

    SReents:

    I am unclear what the behavior is if we delete the entire server, but my best assumption would be that these clients would still have to be deleted manually. 

    I do not have a test server that i can delete at the moment to try it out. 

     

    Thanks for the help.  I guess we will see then!

  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 04-20-2016, 2:26 PM

    Hello everybody

    Is there any tricky method to automate deleting unused zombie VM pseudo clients from CommServe (or SLA?). Customer has run by accident several times many VMs that should not be run. He killed the job just after start, but all VMs were registered in CommServe as VM client. No valid backup, no even backup history (also with 'show aged data') and right know there are a lot of VM clients that should be deleted to clean up the CommServe/SLA reports.

    I know how to delete it manually or by CLI or exclude them from SLA report, but is there any method to automate this proces? I wonder this sequencey

    - Scan backup history of VM clients

    - If there is no valid job for these VMs - delete VM clients

    Do you have any ideas? VMware environment is really big; by 3 mistakes in past there are ca. 400 zombie-clients to remove and it could be a little be problematic to check all of them (backup history) and then delete manually.

    Regards

  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 06-15-2016, 11:13 AM

    Hello

    Any news or ideas?

  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 09-16-2016, 9:00 AM

    We are experiencing this very issue.  I did notice that this was discussed in another thread back in 2014:

    rpolimera posted in 'Health report 30 day SLA exclude VM's ?' (Posted: 12-30-2014, 10:10 AM)

    In case of deleted VMs, we are going to undiscover the clients and SLA will exclude them from 10 SP10

     

    Almost two years later and we are still waiting...  Im running SP13 and still have this issue.

  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 02-12-2018, 1:28 PM

    How do I undiscover VMs?

    Commvault v11 sp10

  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 02-12-2018, 1:47 PM
  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 02-12-2018, 2:04 PM

    Thanks. But this is not what i am looking for. This will require manually excluding clients every now and then.

    I am looking for excluding dummy VM clients automatically which is described in the thread discussion above.

  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 03-06-2018, 10:54 AM

    we are having this problem in our envirnoment.

    we removed two VM's from being backup.

    those Vm's are now reported on missed SLA report.

     

    Is there any alternative way to exclude this vm from report other than updating properties on client for  exclude SLA?

    On other hand we don't want to hard delete our VM, because the backup data still exist for those VM for a while. 

  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 03-06-2018, 6:15 PM

    Hello cvlt-user,

     

    As discussed above, this can be done on a VM to VM basis, rather than doing so on the virtualization client or the subclient containing all of your VMs. This will also mean that you do not have to delete the VM client from the console.

     

    You can specificially excluse the VM client from SLAs, but first you will need to enable an option to disaply these VM clients.

     

    Right click on client computers > customize view > show Virtual Machines.

     

    You can then find the specific VM you are looking to exclude, right click > properties > advanced > KPIs > Exclude from SLA count.

     

    Please let me know if this solves your issues

     

    Kind regards

     

    Allister

  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 03-19-2018, 7:31 AM

     

    How do you do this from VM that never existed?  We did a restore to VM a few weeks ago and everything looks ok under clients except there is one that shows up in the SLA report that has a _1 after the name. Since it never existed how do you excluded it? Since it never shows up in the client list because it never had that name. We are also see server show up on the list that are still getting backed up.

     

  • Re: CommVault SLA report showing old VMWARE servers still
    Posted: 03-19-2018, 7:35 AM

    How do you do this from VM that never existed?  We did a restore to VM a few weeks ago and everything looks ok under clients except there is one that shows up in the SLA report that has a _1 after the name. Since it never existed how do you excluded it? Since it never shows up in the client list because it never had that name. We are also see server show up on the list that are still getting backed up.

     

     

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2018 Commvault | All Rights Reserved. | Legal | Privacy Policy