Backup Filters Settings not working

Last post 04-01-2020, 9:07 AM by Liam. 5 replies.
Sort Posts: Previous Next
  • Backup Filters Settings not working
    Posted: 03-31-2020, 4:47 PM

    I have a Commvault client with a Suclient with Content: U:\nfs_datastore-3 which is the main directory. Inside that folder, there is a subdirectory: 


    And inside there directory, there are no files but three additional subdirectories:

    U:\nfs_datastore-3\Backup\BDN, U:\nfs_datastore-3\Backup\CDN, U:\nfs_datastore-3\Backup\EDN

    And each have large files which I do NOT want to back up.

    In the Filters tab, in the Exclude these files/folders/patterns: box I've added several combinations to try to not backup everything under U:\nfs_datastore-3\Backup\ such as:




    But whenever I do an Incremental and Synthetic Full backup, the contents of every under the \Backup\ including the three subfolders still gets backed up according to their backup contents.


    Attached is a screenshot. 

    Please tell me the correct syntax to filter out everthing in that folder. Thanks.

    Attachment: commvault_filters.jpg
  • Re: Backup Filters Settings not working
    Posted: 03-31-2020, 5:06 PM

    Hi Jhshen,


    that looks like a network share so you need to specify the UNC path as mentioned here -

    You can filter files and folders from a UNC path. Make sure that the UNC path starts with \\Computer Name\Share\ . For example, \\\C\*.doc  will exclude all the .doc files from the C: drive of mycomputer in the testlab domain.

    Gary Seibak
    Technical Account Manager - Commvault
  • Re: Backup Filters Settings not working
    Posted: 03-31-2020, 5:38 PM

    I tried to add this UNC path to the filter:


    But the three subdirectories and their contents still backup up nevertheless.

  • Re: Backup Filters Settings not working
    Posted: 03-31-2020, 5:59 PM

    are you running an INCR or new FULL backup?

    you may have to wait a while becuase the data was already backed up. The next synthetic full should drop them from the index but it depends on the retention.

    When you run a backup job, the file or folder added is excluded from the backup. If you exclude files that were backed up or archived already, then the subsequent incremental backup operation will mark the file as deleted in the index. The file might be dropped from the synthetic full backup based on your subclient retention settings and storage policy retention settings.


    or you could just a new traditional FULL backup on that client to drop the folders out.

    Gary Seibak
    Technical Account Manager - Commvault
  • Re: Backup Filters Settings not working
    Posted: 03-31-2020, 10:12 PM

    First, on the Filter have I've added both entries:




    and I did a FULL backup, followed by an Incremental Backup, and finally a Synthetic Full backup.

    Unfortunately, the FULL backup contents still showed the subdirectories under U:\nfs_datastore-3\Backup\, the Incremental backup did not produce any backups, while the Synthetic Full backups shows the contents of U:\nfs_datastore-3\Backup\ as well.


    So the Filter is still not working properly.

  • Re: Backup Filters Settings not working
    Posted: 04-01-2020, 9:07 AM
    • Aplynx is not online. Last active: 10-12-2020, 12:13 PM Liam
    • Top 10 Contributor
    • Joined on 05-04-2010
    • New Jersey
    • Master
    • Points 1,884

    Is U: seen as a local drive? It shows up in the browse a mapped drive for a unc share wouldn't do that. If that's the case just browse in the filters and select the backup folder since you are filtering all of it anyway. No reason to use wildcards in that configuration. 

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Copyright © 2020 Commvault | All Rights Reserved. | Legal | Privacy Policy